WirelessNetView

WirelessNetView v1.02
Copyright (c) 2008 Nir Sofer
Web site: http://www.nirsoft.net

Description

WirelessNetView is a small utility that runs in the background, and monitor the activity of wireless networks around you. For each detected network, it displays the following information: SSID, Last Signal Quality, Average Signal Quality, Detection Counter, Authentication Algorithm, Cipher Algorithm, and more.

System Requirements

  • Wireless network adapter.
  • Windows Vista or Windows XP/SP2 with KB918997 update installed. Be aware that under Windows XP with SP2, WirelessNetView won't work at all without installing this update. To download this update, click here.

Versions History

  • Version 1.02:
    • New option: Mark The Best Network To Connect - Mark the network with the highest signal value that doesn't require a network key.
    • Added 'PHY Types' column.
  • Version 1.01:
    • Added support for saving as comma-delimited text file.
    • Fixed bug: The main window lost the focus when the user switched to another application and then returned back to WirelessNetView.
  • Version 1.00: First release.

Using WirelessNetView

In order to start using WirelessNetView, simply run the executable file - WirelessNetView.exe
After running it, the main window displays the list of all wireless networks detected on your area. The list is automatically updated every 10 seconds, so you can see the changes in networks signal. Also, if new wireless networks are detected, they'll be added to the list.

Translating WirelessNetView to other languages

In order to translate WirelessNetView to other language, follow the instructions below:
  1. Run WirelessNetView with /savelangfile parameter:
    WirelessNetView.exe /savelangfile
    A file named WirelessNetView_lng.ini will be created in the folder of WirelessNetView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run WirelessNetView, and all translated strings will be loaded from the language file.
    If you want to run WirelessNetView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com